Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: That didn't go so well,,,

That didn't go so well,,, 20 May 2017 01:49 #1

  • Car2n
  • Car2n's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Avanti 2955
  • Posts: 70
  • Thank you received: 9
Launched my 1989 Avanti 2955 today.
Started the engine (single 460 king cobra) and it started and ran well but that was short lived.
It overheated very badly because the water was not being circulated. It got so hot that it was smoking at the manifolds and risers,crackling and popping loudly. I shut the engine off and it continued to stumble run for a good 30-40 seconds. The engine was run for about 5 minutes.
Brand new impeller (verified to be installed correctly) was melted and started to have the fins ripped off. It appears to have been run dry. It looks like it wasn't sucking or pumping water.
This was the first run of the season in the water. Never run on land with muffs.

Thoughts??

Please Log in or Create an account to join the conversation.

That didn't go so well,,, 20 May 2017 02:21 #2

  • Dave907
  • Dave907's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 51
  • Thank you received: 6
Impellers can be "air locked" when a boat is out of the water and then put back in. Sometimes this requires that you prime the pump. How you do this depends on your particular configuration, but in general, a good idea is to disconnect the water intake line from the pump before you start the engine for the first time, ensure that water is flowing freely through the line, then reconnect it to the pump.

Dave

Please Log in or Create an account to join the conversation.

Dave Stephens
1988 3218 "Raven"
Cordova, Alaska

That didn't go so well,,, 20 May 2017 02:52 #3

  • brad4550
  • brad4550's Avatar
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 350
  • Thank you received: 42
Sorry that happened ...however and I hope not,if the engine needs major repair or replacement you sucked up someone's ice bag right!!"...just saying. Good luck Brad

Please Log in or Create an account to join the conversation.

Brad & Sharon
Lady Jake
1985 4550 EH 700TI /Twin Disc 502
LaConner,Wa. (summer)
2003 Scout CC 24' W/225 Yamaha
kailua Kona,Hi (Winter)

That didn't go so well,,, 20 May 2017 04:12 #4

  • builderdude
  • builderdude's Avatar
  • Away
  • Platinum Member
  • Platinum Member
  • "THE FIX"
  • Posts: 4489
  • Thank you received: 699
I'm not familiar with the cobra. Do you have an engine mounted raw water pump or is it in the drive? Raw water cooled engine or closed cooled? 5 minutes may have toasted the exhaust components but if she's closed cooled your engine may be ok. What did the temp gauge read?

Please Log in or Create an account to join the conversation.

Dave
Edmonds, WA
"THE FIX"
'93 Ciera 2556 Mercruiser 5.7 Bravo II
.030 over-Vortec top end-part closed cooled
***The rebuild of my 2556***
www.baylinerownersclub.org/index.php/for...ansom-repair-my-2556

That didn't go so well,,, 20 May 2017 04:39 #5

  • Pcpete
  • Pcpete's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 1023
  • Thank you received: 214
I'm not familiar with the king cobra either but, does the raw water enter the system through the drive on your boat or do you pick it up via a thru hull and strainer system. If you have the thru hull pickup, was the valve open? Just throwing the stuff at the wall to see what sticks......

Please Log in or Create an account to join the conversation.

P/C Pete
Edmonds Yacht Club (Commodore 1993)
1988 3818 "GLAUBEN"
1980 Encounter Sunbridge "Misty Blue" (Sold)
MMSI 367770440
1972 Chevrolet Nova Frame off Resto-mod in the garage
Boating on the Salish Sea since 1948
  • Page:
  • 1
Moderators: Jim GandeeRuffryder
Time to create page: 0.077 seconds
Powered by Kunena Forum